Back to overview
Maintenance

Premium System Upgrade

Sep 15 at 01:57pm CEST  –  Sep 18 at 06:44pm CEST
Affected services
Billing Portal

Resolved
Sep 18 at 06:44pm CEST

We have completed the maintenance and everything is running smoothly. We have fully tested the premium system and we can also give people lifetime premium again, well, lifetime. If you delete your account yourself, then it is your own fault.

Created
Sep 15 at 01:57pm CEST

We are going to overhaul the entire premium system so that after the major update it works 100% perfectly and smoothly.