Back to overview
Maintenance

Major maintenance

Sep 21 at 11:11am CEST  –  Sep 21 at 04:23pm CEST
Affected services
Ricardoneud.com
Billing Portal

Resolved
Sep 21 at 04:23pm CEST

We have completed the maintenance and the invoices are now working properly in the interface and the auth system migration is completed. Thank you for your patience.

Created
Sep 21 at 11:11am CEST

🔐 System Changes & Upcoming Improvements

Hey everyone 👋 we have an important systems update to share.

🔹 Login & Authentication Migration

From now on, all login, registration, OAuth2, and password recovery features will move from the main domain to:
🔗 auth.ricardoneud.com

We noticed that many major companies follow this approach, and it provides a cleaner, more secure, and easier-to-manage setup.
So we decided — why not us?

💳 Billing Portal Enhancements

Once this migration is completed, we will perform maintenance on the billing portal.
This includes:

  • Improving the premium system for smoother performance
  • Optimizing invoices so they load faster
  • Adding further improvements to ensure stability and speed

🚀 Pushing Towards 2026

All of these changes are part of our mission to make everything better, faster, and smoother as we move into 2026.
We are working hard to make sure the infrastructure is future-ready and that your experience continues to improve.