Back to overview
Maintenance

Custom Plan/New Billing Integration

Nov 04 at 05:24pm CET  –  Nov 05 at 09:16am CET
Affected services
Ricardoneud.com
Billing Portal
Subscription's Checks

Resolved
Nov 05 at 09:16am CET

Everything appears to be working as expected. We quickly fixed one minor issue and verified it through retesting.

With this, the maintenance is now complete, and the Custom Plan is fully implemented. If you ever have the Custom Plan and notice any incorrect limits or bugs, please let us know so we can address them immediately.

Updated
Nov 05 at 08:59am CET

The affiliate system update for custom USD credit amounts has been successfully implemented. We are now assigning the Custom Plan to our internal account for testing.

Each test will be conducted at least twice to ensure reliability. Any issues identified during testing will be promptly resolved, followed by a full retest to confirm system stability and accuracy.

Updated
Nov 05 at 08:52am CET

All limits for the Custom Plan have been fully implemented. We are now updating the affiliate system to support custom USD amounts for credit rewards.

Once this adjustment is completed, we will proceed with comprehensive testing to ensure all functionalities operate correctly and as intended.

Updated
Nov 04 at 10:18pm CET

The Custom Plan has been added to the billing portal. Tomorrow, we will continue adjusting the plan to ensure the limits function correctly for Custom Plan users.

For now, we have quickly updated the cronjob so that users can still downgrade from the Custom Plan to Enterprise. This is the final change for today, with the remaining adjustments scheduled for tomorrow.

Updated
Nov 04 at 07:32pm CET

We have decided to keep the current Stripe setup for now. Invoice customization will be postponed until we have a KVK and VAT number, as these are required on invoices once registered.

Implementing these changes now would require additional time and effort to update all existing Stripe data. Therefore, this upgrade has been temporarily put on hold.

We will now continue with the integration of the Custom Plan on the platform.

Updated
Nov 04 at 07:18pm CET

The new billing notifications have been implemented. Users now receive:

  • An email 7 days before subscription expiration
  • An email on the day of expiration, indicating the 3-day grace period remaining
  • Notifications when a trial ends or a plan is downgraded

Upgrade notifications are not yet implemented; we are reviewing how to include these and whether they will be part of the system.

We are now proceeding with updating the billing portal so that invoice emails are customized and no longer use Stripe’s default design.

Updated
Nov 04 at 06:27pm CET

We have decided to keep the current billing system as it is. However, renewal reminder emails will now be sent 7 days before a subscription expires.

Only paid invoices will be generated after a successful payment, but users will still receive an early reminder and have the option to renew their subscription 7 days in advance. The 3-day grace period after expiration remains in place, providing extra time before a subscription fully lapses.

We strongly recommend renewing on time to ensure uninterrupted access to all services.

Updated
Nov 04 at 06:00pm CET

The scheduled maintenance will begin tomorrow around 6–7 PM. We aim to have the Custom Plan fully implemented the same day.

However, this update requires additional adjustments due to the custom limits functionality, which may extend the process slightly. We will continue to work diligently to complete the implementation as efficiently as possible.

Created
Nov 04 at 05:24pm CET

We will be performing scheduled maintenance to add the Custom Plan to our platform. This update involves significant backend adjustments and may take several days to complete.

At this time, we do not have a precise estimated time of completion, but we aim to finalize the maintenance within one week. During this period, services will remain operational, though minor disruptions may occur while the new plan is integrated.

We appreciate your patience as we work to enhance our platform and deliver this new feature.