GEO IP - Database Issues
Resolved
Nov 05 at 08:04am CET
The issue has been resolved. We have implemented a check that checks whether the database on our server is one day old. If so, it requests the data from our geo-ip provider again. If the database does not yet exist, it creates it immediately. Otherwise, it simply updates it daily. We can no longer be rate-limited because we can only pull 5 times a day without our token being reset. Now it only pulls once a day. Therefore, the database was updated immediately during this update because it detected that it is an outdated database.
Affected services
Updated
Nov 04 at 10:57pm CET
We have found the root cause, but because it is now outside office hours, the team is no longer available. We will implement a fix tomorrow and then immediately provide a rate limit system so that this does not happen again. We have been blocked by the database provider from which we request the data daily. Therefore, the token was rotated, which caused the root cause.
Affected services
Created
Nov 04 at 10:48pm CET
We are investigating an issue that is causing the GEO IP database to no longer be updated daily. Our team is investigating the issue and will implement a fix as soon as we find the root cause. The API will continue to work, but without daily database updates.
Affected services